node.js 版本不对,

  • node.js 版本不对,已关闭评论
  • 94 次浏览
  • A+
所属分类:Web前端
摘要

1.在知道版本的情况下,用nvm切换一下对应的版本应该就没问题了。在运行前端程序的时候。经常会遇到node.js版本不对的情况。今天我也碰到了这个情况。经查询查,发现了一个node版本控制器,个人觉的比较好用(NVM)具体下载,操作啥的就自己百度查看吧。我这里就不多说了。下载地址——-https://nvm.en.softonic.com/。

1.在知道版本的情况下,用nvm切换一下对应的版本应该就没问题了。

在运行前端程序的时候。经常会遇到node.js版本不对的情况。今天我也碰到了这个情况。经查询查,发现了一个node版本控制器,个人觉的比较好用(NVM)具体下载,操作啥的就自己百度查看吧。我这里就不多说了。下载地址-------https://nvm.en.softonic.com/。

2.如果不知道node.js版本,那就用新版本(我用的是18.14.0,sass:1.26.5------------------sass-loader:8.0这两个是和18.14.0对应),然后升级一下node.js,按下图标注的三个位置进行修改即可。

node.js  版本不对,

 

 

修改完后就可以:npm install  进行安装了。       

到此你的前端项目就可以了。直接运行:npm run dev  启动项目即可。