VS2015项目.net-framework-4.5.2升级或新建项目无法选择framework 4.6.2(解决办法)

  • VS2015项目.net-framework-4.5.2升级或新建项目无法选择framework 4.6.2(解决办法)已关闭评论
  • 92 次浏览
  • A+
所属分类:.NET技术
摘要

VS2015默认安装的目标框架最高是.NET Framework 4.6.1,但是我的项目里面某些NuGet软件包更新需要依赖.NET Framework 4.6.2,项目就需要升级到目标框架.NET Framework 4.6.2
VS2015项目无法选择framework 4.6.2的解决办法:


VS2015里面没有.NET Framework 4.6.2

VS2015默认安装的目标框架最高是.NET Framework 4.6.1,但是我的项目里面某些NuGet软件包更新需要依赖.NET Framework 4.6.2,项目就需要升级到目标框架.NET Framework 4.6.2
VS2015项目无法选择framework 4.6.2的解决办法:

第一步:系统环境安装.NET Framework 4.6.2

官网下载地址 Download .NET Framework 4.6.2
https://dotnet.microsoft.com/zh-cn/download/dotnet-framework/net462
建议下载“脱机安装程序”,包括英文版安装所需的所有内容。下载安装程序后,无需 Internet 连接。
“开发人员工具包”:是否要生成应用? 软件开发人员使用开发人员包创建在 .NET Framework 上运行的应用程序(通常使用 Visual Studio)。
“运行应用 - 运行时 ”:是否要运行应用? 运行时包括运行使用 .NET Framework 生成的现有应用/程序所需的一切内容。

开发人员工具包,运行时安装包两个都需要!加上各自的“中文(简体)”语言包,总共是4个包:

  • ndp462-kb3151800-x86-x64-allos-enu.exe # 运行应用运行时(离线)安装包,安装顺序1

  • ndp462-kb3151800-x86-x64-allos-chs.exe # 运行应用运行时(离线)中文(简体)语言安装包,安装顺序2

  • ndp462-devpack-kb3151934-enu.exe # 开发人员工具包(离线)安装包,安装顺序3

  • ndp462-devpack-kb3151934-chs.exe # 开发人员工具包(离线)中文(简体)语言安装包,安装顺序4

安装和卸载 .NET Framework 受阻疑难解答
https://learn.microsoft.com/zh-cn/dotnet/framework/install/troubleshoot-blocked-installations-and-uninstallations?redirectedfrom=MSDN

安装成功后,在“控制面板 -> 程序和功能”里面能看到“Microsoft .NET Framework 4.6.2 ***”相关的几个程序,说明系统环境上安装好了。
发布后的生产线上服务器可以不安装开发人员工具包,仅安装运行应用运行时包就行。

第二步:VS2015项目选择目标框架.NET Framework 4.6.2

系统已安装了.net framework 4.6.2,但在新建项目的时候没有此版本可选。
解决:framework安装包分为环境安装包和开发人员工具包两个版本,环境安装包装完只是可以运行该版本开发的程序,而要在VS里先择的话,需要下载安装开发人员工具包。
确认上一步的开发人员工具包安装成功后,关闭并重启VS2015或 VS Code工具。
重启后等待加载完,在项目名称右键“属性”,然后“应用程序 -> 目标框架”里面就能看见.NET Framework 4.6.2选项了。

如果是解决方案里多个项目分层互相引用的,应该从最底层的项目开始逐一往上一层项目调整。

第三步:更新NuGet软件包

项目的目标框架更新后,会有错误:一些 NuGet 程序包是使用不同于当前目标框架的目标框架安装的,可能需要重新安装。
“项目名称”展开里面“引用”右键“管理NuGet程序包”,点击“更新”,里面可以选择需要更新升级的软件包了。逐一看右边说明里面依赖的目标框架版本哦!

更新完了之后,,可以查看项目目录下的packages.config,可以看到里面各软件都变成了 targetFramework="net462"
然后,我们查看web项目底下的Web.config 里面:

 <system.web>     <authentication mode="None"/>     <compilation debug="true" targetFramework="4.6.2"/>     <httpRuntime targetFramework="4.5.2"/> 

手工修改成 <httpRuntime targetFramework="4.6.2"/>
最后在web项目上“重新生成”,发现自动更新了所有相关的软件包。
全部生成成功,去访问一下试试吧 _