Centos安装Docker和Docker Compose

  • Centos安装Docker和Docker Compose已关闭评论
  • 88 次浏览
  • A+
所属分类:linux技术
摘要

本文介绍如何使用Centos服务器部署Docker和Docker Compose.本文中的命令使用的是root用户登录执行, 若不是root用户要注意权限问题.
笔者这里使用的是阿里云服务器, Linux版本为Centos 7.9, 使用SSH远程连接到服务器.

本文介绍如何使用Centos服务器部署Docker和Docker Compose.

背景信息

本文中的命令使用的是root用户登录执行, 若不是root用户要注意权限问题.
笔者这里使用的是阿里云服务器, Linux版本为Centos 7.9, 使用SSH远程连接到服务器.

安装Docker

docker对Linux内核版本的最低要求是3.10, 3.8以上貌似也可以
首先查看当前的内核版本, 我这里是3.10版本, 满足条件

uname -r 

Centos安装Docker和Docker Compose

更新yum包

yum -y update 

卸载旧版本(若以前安装过的话)

yum remove docker  docker-common docker-selinux docker-engine 

Centos安装Docker和Docker Compose

安装所需软件包

yum install -y yum-utils device-mapper-persistent-data lvm2 

设置yum源

yum-config-manager --add-repo http://download.docker.com/linux/centos/docker-ce.repo (中央仓库) yum-config-manager --add-repo http://mirrors.aliyun.com/docker-ce/linux/centos/docker-ce.repo (阿里仓库) 

直接安装

yum -y install docker 

Centos安装Docker和Docker Compose

或选择docker版本并安装

yum list docker-ce --showduplicates | sort -r 

Centos安装Docker和Docker Compose

yum -y install docker-ce-18.03.1.ce 

查看docker版本

docker version 

启动docker并设置开机自启

systemctl start docker systemctl enable docker 

Centos安装Docker和Docker Compose

安装Docker- compose

这里笔者测试了网上使用较多的使用curl命令在GitHub或国内镜像上下载的方式, 在赋予可执行权限后, 执行docker-compose --version出现错误, 错误内容为:

/usr/local/bin/docker-compose:行1: html: 没有那个文件或目录 /usr/local/bin/docker-compose:行2: 未预期... 

出现这个错误的原因为在Linux中通过curl命令拉取高速安装版本, 可能导致下载不全, 结果就是出现报错.

解决方法为在本地下载后上传到服务器, 我是从GitHub链接上下载的最新Linux发行版(docker-compose-linux-x86_64)

下载后将其上传到服务器的/usr/local/bin目录下, 并重命名

mv docker-compose-linux-x86_64 docker-compose 

将可执行权限应用于二进制文件

chmod +x /usr/local/bin/docker-compose  

创建软链接

ln -s /usr/local/bin/docker-compose /usr/bin/docker-compose 

Centos安装Docker和Docker Compose

Over!