yum update更新报错 Transaction Check Error 解决方法

  • yum update更新报错 Transaction Check Error 解决方法已关闭评论
  • 86 次浏览
  • A+
所属分类:linux技术
摘要

yum update 引起错误Transaction Check Error的原因很多,要根据错误概要去判断具体原因。


yum update更新报错 Transaction Check Error 解决方法

yum update 引起错误Transaction Check Error的原因很多,要根据错误概要去判断具体原因。

错误现象:

yum update更新报错 Transaction Check Error 解决方法

报错内容: file /usr/share/man/man1/gtk-query-immodules-2.0.1.gz from install of gtk2-2.24.31-1.el7.x86_64 conflicts with file from package gtk2-2.24.31-1.el7.i686

字面意思:文件 /usr/share/man/man1/gtk-query-immodules-2.0.1.gz 来自 gtk2-2.24.31-1.el7.x86_64 安装与软件包 gtk2-2.24.31-1.el7.i686 中的文件冲突

报错分析:gtk2-2.24.31-1.el7.x86_64   与  gtk2-2.24.31-1.el7.i686  两个软件因架构不一致产生冲突。

解决方法:

查询/验证所有gtk2相关软件包:rpm -qa | grep gtk2  ,发现确有 gtk2-2.24.31-1.el7.i686 该导致冲突软件。

清除 (卸载) 软件包:rpm -e gtk2-2.24.31-1.el7.i686

 

 

 

rpm --help  用法: rpm [选项...]  查询/验证软件包选项:   -a, --all                        查询/验证所有软件包   -f, --file                       查询/验证文件属于的软件包   -g, --group                      查询/验证组中的软件包   -p, --package                    查询/验证一个软件包   --pkgid                          query/verify package(s) with package identifier   --hdrid                          query/verify package(s) with header identifier   --triggeredby                    query the package(s) triggered by the package   --whatrequires                   query/verify the package(s) which require a dependency   --whatprovides                   查询/验证提供相关依赖的软件包   --nomanifest                     不把非软件包文件作为清单处理  查询选项(用 -q 或 --query):   -c, --configfiles                列出所有配置文件   -d, --docfiles                   列出所有程序文档   -L, --licensefiles               list all license files   --dump                           转储基本文件信息   -l, --list                       列出软件包中的文件   --queryformat=QUERYFORMAT        使用这种格式打印信息   -s, --state                      显示列出文件的状态  验证选项(用 -V 或 --verify):   --nofiledigest                   不验证文件摘要   --nofiles                        不验证软件包中文件   --nodeps                         不验证包依赖   --noscript                       不执行验证脚本  安装/升级/擦除选项:   --allfiles                       安装全部文件,包含配置文件,否则配置文件会被跳过。   --allmatches                     移除所有符合 <package> 的软件包(如果 <package>                                    被指定未多个软件包,常常会导致错误出现)   --badreloc                       对不可重定位的软件包重新分配文件位置   -e, --erase=<package>+           清除 (卸载) 软件包   --excludedocs                    不安装程序文档   --excludepath=<path>             略过以 <path> 开头的文件   --force                          --replacepkgs --replacefiles 的缩写   -F, --freshen=<packagefile>+     如果软件包已经安装,升级软件包   -h, --hash                       软件包安装的时候列出哈希标记 (和 -v 一起使用效果更好)   --ignorearch                     不验证软件包架构   --ignoreos                       不验证软件包操作系统   --ignoresize                     在安装前不检查磁盘空间   -i, --install                    安装软件包   --justdb                         更新数据库,但不修改文件系统   --nodeps                         不验证软件包依赖   --nofiledigest                   不验证文件摘要   --nocontexts                     不安装文件的安全上下文   --noorder                        不对软件包安装重新排序以满足依赖关系   --noscripts                      不执行软件包脚本   --notriggers                     不执行本软件包触发的任何脚本   --nocollections                  请不要执行任何动作集   --oldpackage                     更新到软件包的旧版本(带 --force 自动完成这一功能)   --percent                        安装软件包时打印百分比   --prefix=<dir>                   如果可重定位,便把软件包重定位到 <dir>   --relocate=<old>=<new>           将文件从 <old> 重定位到 <new>   --replacefiles                   忽略软件包之间的冲突的文件   --replacepkgs                    如果软件包已经有了,重新安装软件包   --test                           不真正安装,只是判断下是否能安装   -U, --upgrade=<packagefile>+     升级软件包   --reinstall=<packagefile>+       reinstall package(s)  所有 rpm 模式和可执行文件的通用选项:   -D, --define=“MACRO EXPR”        定义值为 EXPR 的 MACRO   --undefine=MACRO                 undefine MACRO   -E, --eval=“EXPR”                打印 EXPR 的宏展开   --macros=<FILE:…>                从文件 <FILE:...> 读取宏,不使用默认文件   --noplugins                      don't enable any plugins   --nodigest                       不校验软件包的摘要   --nosignature                    不验证软件包签名   --rcfile=<FILE:…>                从文件 <FILE:...> 读取宏,不使用默认文件   -r, --root=ROOT                  使用 ROOT 作为顶级目录 (default: "/")   --dbpath=DIRECTORY               使用 DIRECTORY 目录中的数据库   --querytags                      显示已知的查询标签   --showrc                         显示最终的 rpmrc 和宏配置   --quiet                          提供更少的详细信息输出   -v, --verbose                    提供更多的详细信息输出   --version                        打印使用的 rpm 版本号  Options implemented via popt alias/exec:   --scripts                        list install/erase scriptlets from package(s)   --setperms                       set permissions of files in a package   --setugids                       set user/group ownership of files in a package   --setcaps                        set capabilities of files in a package   --restore                        restore file/directory permissions   --conflicts                      list capabilities this package conflicts with   --obsoletes                      list other packages removed by installing this package   --provides                       list capabilities that this package provides   --requires                       list capabilities required by package(s)   --info                           list descriptive information from package(s)   --changelog                      list change logs for this package   --xml                            list metadata in xml   --triggers                       list trigger scriptlets from package(s)   --last                           list package(s) by install time, most recent first   --dupes                          list duplicated packages   --filesbypkg                     list all files from each package   --fileclass                      list file names with classes   --filecolor                      list file names with colors   --fscontext                      list file names with security context from file system   --fileprovide                    list file names with provides   --filerequire                    list file names with requires   --filecaps                       list file names with POSIX1.e capabilities  Help options:   -?, --help                       Show this help message   --usage                          Display brief usage message