可为 null 的引用类型”在 C# 7.3 中不可用。请使用 8.0 或更高的语言版本

  • 可为 null 的引用类型”在 C# 7.3 中不可用。请使用 8.0 或更高的语言版本已关闭评论
  • 190 次浏览
  • A+
所属分类:.NET技术
摘要

在使用 using 等新语法时,在 VisualStudio 2019 会自动判断框架版本,如在 net 45 就不会自动使用最新版本的语法,需要修改项目文件

在使用 using 等新语法时,在 VisualStudio 2019 会自动判断框架版本,如在 net 45 就不会自动使用最新版本的语法,需要修改项目文件

在使用 C# 8.0 之前,请在官网 下载最新的 VisualStudio 2019 版本

如果在编译时提示

“Using 声明”在 C# 7.3 中不可用。请使用 8.0 或更高的语言版本
1.

登录后复制
error CS8370: 功能“可为 null 的引用类型”在 C# 7.3 中不可用。请使用 8.0 或更高的语言版本。
1.
解决方法是在 csproj 项目文件里面添加下面代码

<PropertyGroup>
<LangVersion>preview</LangVersion>
</PropertyGroup>
1.
2.
3.
如果不知道写在哪,请看 csproj 文件

<Project Sdk="Microsoft.NET.Sdk">

<PropertyGroup>
<OutputType>Exe</OutputType>
<TargetFramework>net45</TargetFramework>
<LangVersion>preview</LangVersion>
</PropertyGroup>

</Project>
-----------------------------------
©著作权归作者所有:来自51CTO博客作者lindexi的原创作品,请联系作者获取转载授权,否则将追究法律责任
dotnet 修复 C# 8.0 语法编译失败
https://blog.51cto.com/u_11283245/5237505