NET6关于包降级报错问题

  • NET6关于包降级报错问题已关闭评论
  • 118 次浏览
  • A+
所属分类:.NET技术
摘要

前两天同事更新包后,发现相关的授权还没到位(没买这个版本),所以需要降级回原有版本。

前两天同事更新包后,发现相关的授权还没到位(没买这个版本),所以需要降级回原有版本。

本来我本地没有拉取最新时,编译是没问题的,但是更新后再修改回来,就有问题了。

Severity Code Description Project File Line Suppression State
Error NU1605 Warning As Error: Detected package downgrade: ExcelUtilCore from 1.1.0 to 1.0.2. Reference the package directly from the project to select a different version.

网上搜了半天,大部分是.NET平台升级的包问题,关于1605的信息很少,而且也不准确,所以记录一下。

 

1,为什么会报错

  在项目的property里,默认1605是当报错的

NET6关于包降级报错问题

 

 

 2,处理方法

  在设置这里去掉1605重新编译没有用,此时会生成如下代码

<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Debug|AnyCPU'">
  <WarningsAsErrors>$(WarningsAsErrors)</WarningsAsErrors>
</PropertyGroup>

<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|AnyCPU'">
  <WarningsAsErrors>$(WarningsAsErrors)</WarningsAsErrors>
</PropertyGroup>

  <WarningsAsErrors>$(WarningsAsErrors)</WarningsAsErrors> 并不是我们需要的,需要添加<NoWarn>NU1605</NoWarn>才能编译通过。

  所以正确的配置如下

<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Debug|AnyCPU'">
  <NoWarn>NU1605</NoWarn>
</PropertyGroup>

<PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|AnyCPU'">
  <NoWarn>NU1605</NoWarn>
</PropertyGroup>