欢迎光临
我的个人博客网站

rabbitmq-server的安装与升级


下载地址

rabbitmq和erlang的对应版本:https://www.rabbitmq.com/which-erlang.html
rabbitmq-server包下载地址:https://github.com/rabbitmq/rabbitmq-server/releases
erlang包下载地址:https://github.com/rabbitmq/erlang-rpm/releases
socat包下载地址:https://pkgs.org/download/socat

安装

安装之前需要查看自己系统的版本

# uname -a Linux admin.blog.test 3.10.0-1160.21.1.el7.x86_64 #1 SMP Tue Mar 16 18:28:22 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux 

可以看到我的系统是el7.x86_64版本的。下载rabbitmq-server、erlang、socat都需要和系统版本对应
安装rabbitmq-server前必须安装erlang和socat,因为rabbitmq-server需要依赖这两个。

安装socat

安装socat只需要装最新的就ok了

wget http://mirror.centos.org/centos/7/os/x86_64/Packages/socat-1.7.3.2-2.el7.x86_64.rpm rpm -ivh socat-1.7.3.2-2.el7.x86_64.rpm 

-i 代表install, -v 和 -h 只不过是打印操作日志的一些参数设置

我的系统是el7.x86_64版本的,所以下载该版本
rabbitmq-server的安装与升级

安装erlang

首先去查看rabbitmq-server版本对应的erlang版本,erlang下载地址:https://www.rabbitmq.com/which-erlang.html

rabbitmq-server的安装与升级

那么就去下载erlang的23.x最新版本吧。

wget https://github.com/rabbitmq/erlang-rpm/releases/download/v23.3.1/erlang-23.3.1-1.el7.x86_64.rpm rpm -ivh erlang-23.3.1-1.el7.x86_64.rpm 

安装rabbitmq-server

安装完erlang和socat后,才可以安装rabbitmq-server,下载地址:https://github.com/rabbitmq/rabbitmq-server/releases
找到系统对应的rabbitmq-server版本和密钥进行下载:
rabbitmq-server的安装与升级

首先导入密钥

rpm -import https://github.com/rabbitmq/rabbitmq-server/releases/download/v3.8.14/rabbitmq-server-3.8.14-1.el7.noarch.rpm.asc 

下载并安装rabbitmq-server

wget https://github.com/rabbitmq/rabbitmq-server/releases/download/v3.8.14/rabbitmq-server-3.8.14-1.el7.noarch.rpm rpm -ivh rabbitmq-server-3.8.14-1.el7.noarch.rpm 

此时就应该就安装好rabbitmq-server了。

启动和停止rabbitmq服务

启动rabbitmq服务

nohup /usr/lib/rabbitmq/bin/rabbitmq-server start > rabbitmq.log & 

停止rabbitmq服务

/usr/lib/rabbitmq/bin/rabbitmqctl stop 

升级rabbitmq服务

如果是rabbitmq-server的版本升级跨越稍微比较大,那么erlang版本就可能也需要升级。
此时我把rabbitmq-server降级为3.7.16,erlang版本为21

/usr/lib/rabbitmq/bin/rabbitmqctl version 3.7.16  erl version Erlang/OTP 21 [erts-10.3.5.10] [source] [64-bit] [smp:2:2] [ds:2:2:10] [async-threads:1] [hipe] 

现在要升级rabbitmq-server为3.8.14版本。升级rabbitmq-sever服务前,先停止rabbitmq服务和升级erlang版本。
需要注意的是,升级服务的命令参数为 -Uupgrade,如果是安装服务的命令参数才是 -iinstall

/usr/lib/rabbitmq/bin/rabbitmqctl stop  # 升级erlang版本 rpm -Uvh erlang-23.3.1-1.el7.x86_64.rpm  rpm -Uvh rabbitmq-server-3.8.14-1.el7.noarch.rpm 

那么此时则升级rabbitmq完毕。

rabbitmq管理控制台

启动控制台需要启用rabbitmq_management插件

/usr/lib/rabbitmq/bin/rabbitmq-plugins enable rabbitmq_management 

将RabbitMQ文件的所有权提供给RabbitMQ用户

chown -R rabbitmq:rabbitmq /var/lib/rabbitmq/ 

给rabbitmq管理控制台添加管理员用户

rabbitmqctl add_user admin adminPassword rabbitmqctl set_user_tags admin administrator rabbitmqctl set_permissions -p / admin ".*" ".*" ".*" 

操作完后打开地址http://你的服务IP:15672, 登录后可以查看到这样的界面

rabbitmq-server的安装与升级

总结

以上就是关于rabbitmq服务安装与升级的一些基本操作。

个人博客网址: https://colablog.cn/

如果我的文章帮助到您,可以关注我的微信

赞(0) 打赏
未经允许不得转载:张拓的天空 » rabbitmq-server的安装与升级
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

专业的IT技术经验分享 更专业 更方便

联系我们本站主机

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏