ant design vue, ant-design-vue 安装, ant-design-vue 使用

  • ant design vue, ant-design-vue 安装, ant-design-vue 使用已关闭评论
  • 26 次浏览
  • A+
所属分类:Web前端
摘要

Ant Design Vue 是使用 Vue 实现的遵循 Ant Design 设计规范的高质量 UI 组件库,用于开发和服务于企业级中后台产品。


Ant Design Vue 是使用 Vue 实现的遵循 Ant Design 设计规范的高质量 UI 组件库,用于开发和服务于企业级中后台产品。

ant design vue, ant-design-vue 安装, ant-design-vue 使用

Ant Design Vue

中文文档:Ant-Design-Vue
Github:Ant-Design-Vue
Star:16.9k

微信交流群: 前端攻城狮(点击加入)

特性

  • 提炼自企业级中后台产品的交互语言和视觉风格。
  • 开箱即用的高质量 Vue 组件。
  • 共享Ant Design of React设计工具体系。

支持环境

  • 现代浏览器, 如果需要支持 IE9,你可以选择使用 1.x 版本。
  • 支持服务端渲染。
  • Electron

ant design vue, ant-design-vue 安装, ant-design-vue 使用

版本

稳定版:npm v3.2.10

你可以订阅:https://github.com/vueComponent/ant-design-vue/releases.atom 来获得稳定版发布的通知。

安装

使用 npm 或 yarn 安装

我们推荐使用 npm 或 yarn 的方式进行开发,不仅可在开发环境轻松调试,也可放心地在生产环境打包部署使用,享受整个生态圈和工具链带来的诸多好处。

npm install ant-design-vue --save 
yarn add ant-design-vue 

如果你的网络环境不佳,推荐使用 cnpm

浏览器引入

在浏览器中使用 script 和 link 标签直接引入文件,并使用全局变量 antd。

我们在 npm 发布包内的 ant-design-vue/dist 目录下提供了 antd.js antd.css 以及 antd.min.js antd.min.css。

强烈不推荐使用已构建文件,这样无法按需加载,而且难以获得底层依赖模块的 bug 快速修复支持。

注意:引入 antd.js 前你需要自行引入 dayjs。

示例

import { DatePicker } from 'ant-design-vue'; app.use(DatePicker); 

引入样式:

import 'ant-design-vue/dist/antd.css'; // or 'ant-design-vue/dist/antd.less' 

按需加载

下面两种方式都可以只加载用到的组件。

  • 使用 babel-plugin-import(推荐)。
// .babelrc or babel-loader option {   "plugins": [     ["import", { "libraryName": "ant-design-vue", "libraryDirectory": "es", "style": "css" }] // `style: true` 会加载 less 文件   ] } 

然后只需从 ant-design-vue 引入模块即可,无需单独引入样式。等同于下面手动引入的方式。

// babel-plugin-import 会帮助你加载 JS 和 CSS import { DatePicker } from 'ant-design-vue'; 
  • 手动引入
import DatePicker from 'ant-design-vue/lib/date-picker'; // 加载 JS import 'ant-design-vue/lib/date-picker/style/css'; // 加载 CSS // import 'ant-design-vue/lib/date-picker/style';         // 加载 LESS 
  • Vite 按需
// vite.config.js import Components from 'unplugin-vue-components/vite'; import { AntDesignVueResolver } from 'unplugin-vue-components/resolvers';  export default {   plugins: [     /* ... */     Components({       resolvers: [AntDesignVueResolver()],     }),   ], };